読者です 読者をやめる 読者になる 読者になる

Androidはワンツーパンチ 三歩進んで二歩下がる

Android卵プログラマーの記録ブログ

Androidの SDKをr17にバージョンアップするとEclipseでエラーだらけになった

Android Eclipse

既に色々と情報が出ているのですが、自分用メモです。
Android SDK r17にアップデートしたらVerifyError
【緊急】Android SDK r16→r17にバージョンアップするとEclipseでアプリが正常にビルド、実行が出来なくなる件について

私のところで出たエラーはこのような感じでした。なんかエラーメッセージが上記のサイト様に出てくるのと違う?!ともかく。。。

上記のサイト様を参考に次のような手順でエラーが消えました。

1.プロジェクト右クリックしてビルドパス設定を開く
2.Ordered and Exportのタブの所でチェックが付いていないものにチェックを入れる(下の赤丸のところ)

3.プロジェクトをcleanするとエラーが消えるようだが4のようにエラーが出たときもあった。
4.genフォルダがエラーになっていたりR.javaの参照がうまくいかないようなエラーが出たら、genフォルダを削除する。(genフォルダの中がおかしくなっている)

5.プロジェクトをcleanするとエラーが消える
6.念のためeclipseを -clean オプションを付けて起動

以上で自分はエラーが消えました。